Browse Source

Explicitly require Nix 1.6

People using Nix < 1.6 previously got an unhelpful "infinite
recursion" error.
nsd-state-dir
Eelco Dolstra 8 years ago
parent
commit
14af15dbff
  1. 8
      default.nix
  2. 6
      pkgs/stdenv/generic/default.nix

8
default.nix

@ -1 +1,7 @@
import ./pkgs/top-level/all-packages.nix
if ! builtins ? nixVersion || builtins.compareVersions "1.6" builtins.nixVersion == 1 then
abort "This version of Nixpkgs requires Nix >= 1.6, please upgrade!"
else
import ./pkgs/top-level/all-packages.nix

6
pkgs/stdenv/generic/default.nix

@ -12,12 +12,6 @@ let lib = import ../../../lib; in lib.makeOverridable (
, extraBuildInputs ? []
}:
if ! builtins ? langVersion then
abort "This version of Nixpkgs requires Nix >= 1.2, please upgrade!"
else
let
allowUnfree = config.allowUnfree or true && builtins.getEnv "HYDRA_DISALLOW_UNFREE" != "1";

Loading…
Cancel
Save