Browse Source

Expose minimum required Nix version.

nsd-state-dir
Rommel M. Martinez 7 years ago
parent
commit
31a20f38ac
  1. 2
      default.nix
  2. 2
      lib/minver.nix

2
default.nix

@ -1,4 +1,4 @@
let requiredVersion = "1.10"; in
let requiredVersion = import ./lib/minver.nix; in
if ! builtins ? nixVersion || builtins.compareVersions requiredVersion builtins.nixVersion == 1 then

2
lib/minver.nix

@ -0,0 +1,2 @@
# Expose the minimum required version for evaluating Nixpkgs
"1.10"
Loading…
Cancel
Save